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Abstract:- Wire electrical discharge machining (WEDM) 

is widely used in machining of conductive materials 

when precision is considered as a prime importance. 

This work proposes a three dimensional finite element 

model (using ANSYS software) and new approach to 

predict the temperature distribution at different pulse 

time as well as stress distribution in wire. A transient 

thermal analysis assuming a Gaussian distribution heat 

source with temperature-dependent material properties 

has been used to investigate the temperature distribution 

and stress distribution. Thermal stress developed after 

the end of the spark and residual stress developed after 

subsequent cooling. The effect on significant machining 

parameter pulse-on-time has been investigated and 

found that the peak temperature sharply increases with 

the parameter. 
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I. INTRODUCTION 
 

Wire electrical discharge machining process is a 

mostly used non-conventional material removal processes. 
This is use for manufacturing difficult shape and profile of 

hard materials. This is considering as a distinctive variation 

of the conventional electrical discharge machining 

processes. In the WEDM, demand is growing for high rate 

cutting speed and high accuracy machining for improve the 

productivity of product and also for achieve high excellence 

quality in machining job. In wire electrical discharge 

machining process a always travelling wire electrode made 

of thin copper, brass or tungsten of diameter 0.05–0.3 mm is 

used, which is precisely controlled by a CNC system. Here 

role of CNC is very important. The function of CNC is 

unwind the wire from a first spool, and feed throughout the 
work-piece, and takes it on a second spool. Generally wire 

velocity varies from 0.1 to 10 m/min, and feed rate is 2 to 6 

mm/min. A direct current is used for generate high 

frequency pulse to the wire and the workpiece. The wire 

(electrode) is hold in tensioning device for decreases the 

chance of producing inaccurate parts. In wire electrical 

machining process, the workpiece and tool is eroded and 

there is no direct contact between the workpiece and the 

electrode, and this reduces the stress during machining. 

 

WEDM was initially developed by manufacturing 
industry in the since 1960. The development technique is 

replaced the machined electrode used in electrical discharge 

machining. In 1974, D.H. Dulebohn introduced the optical 

line follower system which is automatic control the shapes 

of the part to be machined by the wire electrical discharge 
machining process. In 1975, it was popular rapidly, and its 

capability was better understood by manufacturing industry. 

When the computer numerical control system was 

introduced in WEDM process this brought about a most 

important development of the machining proce. 

 

Consequently the wide capability of the wire electrical 

discharge machining process was widely exploited for any 

through-hole machining owing to the wire, which has to 

pass through the part to be machined. The common 

application of wire electrical discharge machining process is 

the fabricate the stamp and extrusion tools and dies, fixtures 
and gauges, prototypes, aircraft and medical parts, and 

grinding wheel form tools. 

 

II. MATERIALS AND METHODS 
 

In the wire EDM, a series of rapid electric spark occur 

in the gap between tool (wire) and workpiece. Addition of 

particles into the dielectric fluid makes this process more 

complex and random. The following assumptions are made 

without sacrificing the basic features of the wire EDM 

model to make the problem mathematically feasible. 
 

A. Thermal Model of Wire EDM 

The working principal of WEDM is as same EDM 

process, when the distance between the two electrodes (wire 

and the workpiece) is reduced the intensity of electric field 

in the volume between the electrodes (wire and the 

workpiece), become greater than the strength of the 

dielectric, which breaks, allowing current to flow between 

the two electrodes. For this reason the spark will generated. 

B. Finite Element Analysis Procedure Using ANSYS 

Software 

 
 Thermal Analysis of Brass Wire 

The general finite element modeling procedure consists 

of the following steps: 

 

 Preferences 

 Thermal 

 

 Preprocessing 

 Definition of Element Type 

 Material Properties Definition 

 Model Generation 
 Meshing 
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 Solution 

 Defining Initial Condition 

 Applying Boundary Condition 

 Applying Load 

 Solving For Results 

 

 Post Processing 

 Reading Result File 
 Viewing Results 

 

 Process of Thermo-Structural Modeling 

 Open Mechanical Apdl (Ansys). 

 Go To File > Change Title And Give A New Title For 

The Example. 

 Preferences 

 Preprocessing>Element Type> Add/Edit/Delete 

 

 Click on Add 

 Select Thermal Solid on the Left List and Brick 8 Node 
70 on Right List(I.E. Element Type) Click on Ok 

 Close 

 Material Properties>Temperature Unit>Celsius>Ok 

 Material Models>Thermal >Conductivity>Isotropic>Ok 

,Put Value>Density Put Value>Specific Heat Put 

Value>Material Exit 

 Modeling>Create>Cylinder>Sold Cylinder>Put the 

Dimensions 

 Meshing>Mesh Tool> Smart Size 6>Mesh >Ok 

 

 
Fig 1 Three-Dimensional View of the Meshed Model 

 

 Physics> Environment>Write >Physics File 

Title>Thermal>Ok 

 Element Type>Switch Element Type>Change>Element 

Type>Thermal To Structural>Ok 

 Material 

Properties>Structural>Linear>Isotropic>Thermal 

Expansion>Ok>Exit 

 Physics> Environment>Write >Erase Thermal>Write 
Structural>Ok 

 Solution>New Analysis Type>Transient>Full>Ok 

 Solution Control>Putting The Ton Time> Automatic 

Time Stepping ON>No. Of Subsets 

 Define Loads>Apply>Functions>Read File>Ok 

 Thermal>Heat Flux>On Element>Select Proper 

Element>Ok 

 Initial Condition>Define>Pick All>Temperature>210C 

 Solve >Current LS 

 

 Post Processing>Plot Results>Counter Plot>Nodal 

Solution>DOF Solution>Nodal Temperature>OK 

 Finish 
 Physics> Environment>Read >Structural>Ok 

 Solution Control>Putting The Ton Time> Automatic 

Time Stepping ON>No. Of Subsets 

 Apply>Structural>Displacement>Area>All DOF>OK 

 Solution Load Step>Write LS File>1>Ok 

 Analysis Type>Solution Control>Basic>Off 

Time>Transient>Ramped Loading 

 Defineload>Apply>Temperature>From Thermal 

Analysis>Brouse>File.Rth>Ok 

 

Post processing>plot results>counter plot>nodal 

solution>DOF solution>nodal temperature>OK 
 

III. RESULTS AND DISCUSSION 
 

A. ANSYS Model Confirmation 

In this section we have firstly make a model of WEDM 

process for brass wire with parameter setting as given in 

Table 3. Later the value has been compared with Han et al. 

Fig. 6 shows temperature distribution in brass wire, which is 

approximately same of Han et al. model. So we can say that 

we are proceeding in right way. Thermal modeling has done 

in using ANSYS. 
 

B. FEM Analysis 

 Thermal Modeling of Wire EDM  for Single Spark in 

Brass Wire 

Main parameters of the thermal analysis (analysis 

parameters) 

 

Table 1 Parameters Used for Thermal Analysis in  

WEDM Process 

Parameter Unit Value 

Peak current of electro-

discharge 

A 27 

Voltage of electro 

discharge, 

V 25 

Duration of single pulse µs 0.12, 0.26, 0.36, 
0.52, 0.58, 

Wire radius Mm 1.2, 1.82 

Convective coefficient W/m2 0C 0.05 

Temperature of the 

dielectric Poisson’ ratio 

0C 3040 

Coefficient of linear 

thermal expansion 

K1 21 
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Fig 2  Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton=0.12µs 
 

 
Fig 3  Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton=0.26µs 

 

 
Fig 4  Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton=0.36µs 

 
Fig 5 Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton=0.52µs 

 

 
Fig 6  Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton=0.58µs 

 

 
Fig 7  Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton=1.2µs 
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Fig 8  Temperature Distribution In Brass Wire With V=25V, 

I=27 A, P=0.38 And Ton= 1.82µs 

 

 Structural Modeling of WEDM in Molybdenum Wire 

In this section we have firstly make a model of WEDM 

process for brass wire with parameter setting as given in 

Table 4. Later the value has been compared with Saha et al. 

Fig. 6 shows displacement molybdenum wire, which is 

approximately same of Saha et al. So we can say that we are 

proceeding in right way. The structural analysis has done of 
molybdenum wire. 

 

 Displacement Analysis in the Wire Due to Tension: 

After solving for the temperature distribution we 

attempt to find the displacement in the wire. Now in this 

case molybdenum wire is used. Process parameters used for 

analysis is shown below Table 2 

 

Table 2 Parameters used for structural analysis in  

WEDM process 

Parameter Units Value 

Radius of wire Mm 0.125 

Length of wire M  

Tension N 0.1 

Initial 

temperature 

K  

Working K 13.7295 

 

 The displacement graph is shown in below: 

 

 
Fig 9  Nodal Solution of Displacement 

 
Fig 10 Graph of Displacement 

 

 Thermo-Structural Analysis of WEDM in Brass Wire. 

 Thermal Stress Modelling of Micro Wire EDM for Single 

Discharge 

 

 
Fig 11 Thermal Stress in X-Component at Ton=0.12µs 

 

 
Fig 12 Thermal Stress in Y-Component at Ton=0.12µs 
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Fig 13 Thermal Stress in Z-Component at Ton=0.12µs 

 

 
Fig 14 Thermal Shear Stress in XY Component at 

Ton=0.12µs 

 

 
Fig 15 Thermal shear stress in XZ component at ton=0.12µs 

 
Fig 16 Thermal Shear Stress in YZ-Component at 

Ton=0.12µs 

 

 
Fig 17 Residual Stress at Toff = 3µs 

 

 
Fig 18 Thermal Stress in X-Component at Ton=0.52µs 
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Fig 19 Thermal Stress in Y-component at ton=0.52µs 

 

 
Fig 20 Thermal Stress in Z-Component at Ton=0.52µs 

 

 
Fig 21 Thermal Shear Stress in XY-Component at 

Ton=0.52µs 

 
Fig 22 Thermal Shear Stress in YZ-Component at 

Ton=0.52µs 

 

 
Fig 23 Residual Stress at toff= 3µs 

 

 
Fig 24 Thermal Stress in X-Component at Ton=1.82µs 
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Fig 25 Thermal Stress in Y-Component at ton=1.82µs 

 

 
Fig 26 Thermal Stress in Z-Component at Ton=1.82µs 

 

 
Fig 27 Thermal Stress in XY-Component at Ton=1.82µs 

 
Fig 28 Thermal Stress in XZ-Component at ton=1.82µs 

 

 
Fig 29 Thermal Stress in YZ-Component at ton=1.82µs 

 

 
Fig 30 Residual Stress at Toff= 3 µs 2.5 Results and 

Discussions 

 

Temperature distributions at the end of the pulse time 

are shown in Figs.(3- 9) to know the effects on WEDM. The 
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temperature distribution during single discharge is 

calculated with the energy input constant parameter Ip= 27 

A, voltage =25V with varying pulse time. At pulse time = 

0.12 µs, corresponding temperature is 86.750C. At pulse 

time = 0.26 µs, corresponding temperature is 247.70C. At 

pulse time = 0.36 µs, corresponding temperature is 318.60C. 

At pulse time = 0.52 µs, corresponding temperature is 

446.90C. At pulse time = 0.58 µs, corresponding 
temperature is 578.3350C. At pulse time = 1.2 µs, 

corresponding temperature is 854.80C. At pulse time = 1.82 

µs, corresponding temperature is 11440C. Further increasing 

the pulse time is not possible because, at temperature 

10830C, the brass wire melt. 

 

The distinctive stress distributions in WEDM process, 

enumerated at the end of heating cycle are presented. Here, 

Gaussian heat flux distribution is used for the calculation of 

temperature distribution. Later on, by varying the parameter 

i.e. pulse duration, and study of thermal stresses are 

presented. Fig 10-34 shows the thermal stress in different 
pulse on time. Thermal stress developed after the end of the 

spark and residual stress developed after subsequent 

cooling. The nature of the maximum stress is compressive, 

and it is because during the pulse duration, the heat flux 

supplied to the tool electrode for a very short duration (in 

μs).The maximum compressive stress is 563MPa for 

ton=0.12µs in X-component, and maximum residual stress is 

778 MPa. The maximum compressive stress is 288Mpa for 

ton=0.52µs in Z-component and maximum residual stress is 

288 MPa. The maximum compressive stress is 425Mpa for 

ton=1.82µs in Z-component and maximum residual stress is 
533 MPa. 

 

IV. SUMMARY AND CONCLUSION 
 

In this dissertation, a robust three dimensional finite 

element model has been developed using ANSYS software 

to predict the temperature distribution at different pulse time 

as well as stress distribution in the wire of WEDM. A 

transient thermal analysis assuming a Gaussian distribution 

heat source with temperature-dependent material properties 

has been used to investigate the temperature distribution and 

stress distribution. Thermal stress was developed after the 
end of the spark and also residual stress was developed after 

subsequent cooling. Finite element modeling was carried out 

for a single spark with temperature-dependent material 

properties. Certain parameters such as spark radius, 

discharge current and discharge duration, the latent heat, the 

plasma channel radius and Gaussian distribution of heat 

flux, the percentage of discharge energy transferred to the 

tool electrode have made this study nearer to real process 

conditions. The FE model shows that, at pulse time = 0.12 

µs, corresponding temperature is 86.750C and maximum 

residual stress is 778 Mpa. At pulse time = 0.26 µs, 
corresponding temperature is 247.70C and .At pulse time = 

0.36 µs, corresponding temperature is 318.60C. At pulse 

time = 0.52 µs, corresponding temperature is 446.90C and 

the maximum compressive stress is 288Mpa in Z-

component, and maximum residual stress is 288 Mpa. . At 

pulse time = 0.58 µs, corresponding temperature is 

578.3350C. At pulse time = 1.2 µs, corresponding 

temperature is 854.80C. At pulse time = 1.82 µs, 

corresponding temperature is 11440C and the maximum 

compressive stress is 425Mpa for ton=1.82µs in Z-

component, and maximum residual stress is 533 Mpa. 

 

Further increasing the pulse time is not possible 

because, at temperature 10830C, the brass wire melt. 
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